Paper Title

Paper Subtitle if needed, else delete this paragraph
Don’t add spacing or blank lines before or after the title/subtitle.
	No Author information to be provided until the camera ready copy to ensure double blind review.
	


This Word template can be used to prepare papers for ACM SIGPLAN conference proceedings. It is based on a Latex style file designed for SIGPLAN by Paul C. Anagnostopoulos. The template comes with a set of formatting styles, and also with some macros for applying finishing touches and for handling bibliographic references. Macros must be admitted to enjoy the more advanced features (including support for cross referencing of figures, equations etc.). Note that using this template properly requires some proficiency in Word. Please send all issues regarding the template (not Word!) to steimann, hosted by acm.org.
Categories and Subject Descriptors D.3.3 [Programming Languages]: Language Constructs and Features – abstract data types, polymorphism, control structures. This is just an example, please use the correct category and subject descriptors for your submission from the ACM Computing Classification Scheme found at http://www.acm.org/class/1998/
General Terms Your general terms must be any of the following 16 designated terms: Algorithms, Management, Measurement, Documentation, Performance, Design, Economics, Reliability, Experimentation, Security, Human Factors, Standardization, Languages, Theory, Legal Aspects, Verification.

Keywords Keywords are your own designated keywords, separated by semicolons. E.g.: proof checker; proof-carrying code
1.  Author Area

The author area is a Word table. To insert or remove authors, insert or remove columns through Word’s Table menu. Use this menu also to adjust table and column width. Do it manually (by dragging the borders) only as a last resort. Use the «SIGPLAN Author name», «affiliation», and «email» styles to format your entries. Don’t add additional spacing — distance to title/subtitle and abstract are set as table properties.

Warning: The table is trailed by an invisible section break. If you delete it accidentally, undo (press Ctrl + z) immediately.
2.  Fonts

This template uses Times New Roman for all standard text and headings, Trebuchet MS for email addresses, menus, and other computer expressions (the «SIGPLAN Computer» character style), and Lucida Console for fixed character width expressions (code; the «SIGPLAN Code» character style).
3.  Paragraphs
The first paragraph after a section heading is not indented. Use «SIGPLAN Paragraph 1» for first paragraphs. (You get one automatically by pressing Return at the end of a heading paragraph.) The «SIGPLAN Paragraph 1» style may also be used after lists, equations, enunciations, etc., if the paragraph is a logical continuation of the previous one.

All other paragraphs are indented.

An alternative SIGPLAN style prescribes all non-indented paragraphs with a space of 5 points in between (but only between consecutive paragraphs, not between a paragraph and a heading). This is currently not supported by this template.
4.  Section Headings

Use the «SIGPLAN Section heading», «Subsection heading», and «Sub-subsection heading» paragraph styles for the first three levels of your outline. Note that cross referencing of heading numbers does not work as expected, presumably because these three styles are user-defined and do not override the built-in ones.
Spurious space above paragraphs at the top of a column (as above the heading above) should be removed. This can be done by executing the Finishing Touches macro, which is started by pressing Alt + Ctrl + f.

4.1  Subsection headings
4.1.1  Sub-subsection headings

Spurious space between adjacent headings (as above) should also be removed. This can also be done by the macro.

D-Heads Use «SIGPLAN Paragraph/Subparagraph heading» paragraph style to format the whole paragraph, and «SIGPLAN Paragraph heading» character style to format the heading portion of the paragraph (by marking it and applying the style). Use an em space to separate the heading from the rest of the paragraph. You can insert a default heading and the em space by selecting Insert > AutoText > SIGPLAN Paragraph heading from the menu.

Following paragraphs are formatted with «SIGPLAN Paragraph» (indented, with no space in between).
E-Heads Same as D-Heads, but use «SIGPLAN Subparagraph heading» instead of «SIGPLAN Paragraph heading» character style to format the heading portion of the paragraph.
5.  Figures

Figures should be placed at top or bottom of page and can span one (240 points wide) or both columns (504 points wide). The latter implies that the caption must be placed in a text field. Use the «SIGPLAN Figure caption» paragraph style to format the caption, and set ‘Figure n.’ (including the period) in boldface. Insert an en space behind the period. As with paragraph and subparagraph headings above, you can have the caption inserted automatically by selecting Insert > AutoText > SIGPLAN Figure. Note that you can group the figure and the text field containing the caption to keep them together. If you don’t know how to do this, try to use Figure 1 as an example.

A one-line caption should be centered (as that of Figure 2), two or more lines ragged right (Figure 1). You can use the Finishing Touches macro to have this done automatically. Figures should have a horizontal ruler above and below; the ones below in Figure 1 and Figure 2 are part of the caption; the ones above (which are missing in this template) must be inserted manually. Unfortunately, I found no recommendable way to do so.

6.  Math Displays

There are two recommended ways to insert equations. One is to use a paragraph formatted with the «SIGPLAN Equation» paragraph style, as in

equation

If you want to add an equation number as in

equation
(1)
insert a tab before and after the equation, and insert the SIGPLAN Equation AutoText from the Insert > AutoText menu.

The other is to enter equations in a 1 row 2 column table, with an (optional) right-aligned sequence number (inserted as above) in the right column. Note that tabs don’t work within tables; therefore, the equation is always centered in the table’s first column, which may not be what you want.
	equation 1
equation 2
	(2)


You can have multiple lines within each table row; the equation sequence number is then centered vertically (which is probably the only true advantage of using the table). Note that Word ignores the “no space between paragraphs of same style” setting within tables, so you might prefer to insert a hard line break (by pressing Shift + Return) for more than one line.

You can cross reference an equation from the text, as in (1), in very much the same way as you can reference a figure, simply by using Word’s cross referencing facility (Insert > Reference > Cross Reference > SIGPLAN Equation).

7.  Enunciations

Enunciations are paragraphs containing theorems, lemmas, proofs, etc. Use «SIGPLAN Enunciation» paragraph style for the paragraph and «SIGPLAN Enunciation caption» character style for the caption. Paragraphs following an enunciation need not be indented (i.e., you can use «SIGPLAN Paragraph 1» for subsequent paragraphs).

As with figures and equations, Word’s AutoText feature can be used to insert a template naming (and numbering) the enunciation. For this, choose Insert > AutoText from the menu and select the corresponding entry. If the current paragraph is formatted with the «SIGPLAN Enunciation» paragraph style, the applicable AutoText entries are pre-selected.

Alternatively, you can copy and paste the following paragraphs.
Theorem 1 (name). One em space must follow the period. The name is not set in small caps. The leading text can be inserted using Insert > AutoText > SIGPLAN Theorem.

Proof.  One em space must follow the period. The leading text can be inserted using Insert > AutoText > SIGPLAN Proof.

Lemma 1 (name). One em space must follow the period. The name is not set in small caps. The leading text can be inserted using Insert > AutoText > SIGPLAN Lemma.

Last but not least, you can use (copy and paste) the following paragraph for creating enunciations, and then right-click on “SIGPLAN Enunciation” and select the kind of the enunciation from the context menu. 

SIGPLAN Enunciation
Note that there is excessive space between enunciations in the above example; this can be removed by executing the Finishing Touches macro (Alt + Ctrl + f).

To cross reference a numbered enunciation from the text, you can use Word’s cross referencing facility. For this, you must either add a bookmark manually and reference this, or use the Insert > Reference > Cross Reference function. For the latter option to work, you must have checked the “add custom caption labels for cross referencing” option during the creation of a new SIGPLAN document.
8.  Lists

Use the «SIGPLAN List item» paragraph style for a paragraph containing a list item. This gives you the right space before and after the item. Use the

· «SIGPLAN List bullet», 

1. «SIGPLAN List number», or 

a) «SIGPLAN List letter» 

list style to select the kind of bullet you want. Finally, use Word’s indentation function to push any item to the desired level. To create mixed lists, i.e., lists with different kinds of bullets on different levels, you have to break up the enumeration using the context menu on the bullet you want to change. However, be warned: because lists can be interrupted by ordinary text, Word may think of different lists as belonging together, which may lead to rather surprising formatting effects.
If a list item consists of more than one paragraph, use the «SIGPLAN List paragraph» paragraph style for all paragraphs without a bullet.

9.  Bibliographic References

Word’s native support for bibliographic references is rather weak. This template therefore adds some support in the form of the SIGPLAN Bibliographic reference manager macro, which you may find useful. It is started by pressing Alt + Ctrl + b. To be able to use it, macros must be activated (cf. Footnote 1).

The Bibliographic reference manager lets you add automatically bookmarked entries to the References section of the document (whose heading must be formatted with the «SIGPLAN References heading» style). These entries can be cross referenced from the main text using the manager. Depending on your choice made upon creation of the document (the template instantiation), the text appearing as the cross reference is either an automatically assigned number (as in [1], whose value depends on the position of the entry in the list of references) or a string that you can enter. For the purpose of identification, each bibliographic entry must be given a unique ID, which must not contain spaces or special characters.
10.  Copyright Notice

The copyright notice on page 1 of this template is anchored in the page footer. If you want to change it, you must set Word’s View to Header and Footer.
11.  Disclaimer

This template is still under development. In particular, automated support for figures (e.g., the horizontal rulers required in the ACM SIGPLAN proceedings style specification) is still lacking.

Send all comments, suggestions for improvements, and especially examples of how to do it better, to the address given in the abstract.
The acknowledgments heading is unnumbered. You can use the «SIGPLAN Acknowledgments heading» paragraph style for it (which will save you from deciding whether there should be an ‘e’ after the ‘g’). The trailing tab is automatically added and cannot be deleted. Alternatively, you can use the «SIGPLAN Section heading» paragraph style and backspace the numbering. This lets you write “Acknowledgments” any which way you please.

The appendix, if any, should be placed before the references. In case you have several and want to number them, you can also use the «SIGPLAN Section heading» paragraph style as described above.
[1]
Ingenious Author “My only paper ever read from first to last by anyone other than myself” (2007).
Watch out: The last character in this column is a section break which must not be deleted. If you delete it accidentally, undo (press Ctrl + z) immediately. If you want to even out columns on the last page, delete characters one by one (using Del on your keyboard) until you see the desired effect.
Figure � SEQ SIGPLAN_Figure \* ARABIC �2�. This figure spans one column.








Figure � SEQ SIGPLAN_Figure \* ARABIC �0�. “This figure caption is formatted with the SIGPLAN Figure caption paragraph style. The label “� REF _Ref154328964 \h \* MERGEFORMAT ��Figure 1�” has been inserted by selecting Insert > AutoText > SIGPLAN Figure from the menu (which also inserts the period and the obligatory trailing en space). The label can be referenced from the main text using Word’s cross referencing facility, i.e. by selecting Insert > Reference > Cross Reference and then SIGPLAN Figure as the category. Cross references usually adopt the style of the source in Word, so you have to reformat it, e.g. by selecting the cross reference and pressing Ctrl + Space, and by adding the \* MERGEFORMAT switch to the corresponding field expression (as in { REF _Ref154328964 \h \* MERGEFORMAT }). Note that the caption was grouped with the figure pane (so Word keeps them together), and the group’s properties were set to make it appear at top left of text area, with distance to text 20 points above/below (Word actually applies this space depending on where the figure is placed). The whole thing is anchored, so it moves from page to page with the paragraph containing the anchor. However, you can drag the anchor to whichever paragraph (and thus page) you want. There may be better ways to do figures in Word, but unfortunately I don’t know of any. in the references section at the end of this paper d be thnces with plain text (Alt style. However, in order to cross-reference in the references section at the end of this paper d be thnces with plain text (Alt style. However, in order to cross-reference ”
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Figure � SEQ SIGPLAN_Figure \* ARABIC �0�


Figure � SEQ SIGPLAN_Figure \* ARABIC �0�. “This figure caption is formatted with the SIGPLAN Figure caption paragraph style. The label “� REF _Ref154328964 \h \* MERGEFORMAT ��Figure 1�” has been inserted by selecting Insert > AutoText > SIGPLAN Figure from the menu (which also inserts the period and the obligatory trailing en space). The label can be referenced from the main text using Word’s cross referencing facility, i.e. by selecting Insert > Reference > Cross Reference and then SIGPLAN Figure as the category. Cross references usually adopt the style of the source in Word, so you have to reformat it, e.g. by selecting the cross reference and pressing Ctrl + Space, and by adding the \* MERGEFORMAT switch to the corresponding field expression (as in { REF _Ref154328964 \h \* MERGEFORMAT }). Note that the caption was grouped with the figure pane (so Word keeps them together), and the group’s properties were set to make it appear at top left of text area, with distance to text 20 points above/below (Word actually applies this space depending on where the figure is placed). The whole thing is anchored, so it moves from page to page with the paragraph containing the anchor. However, you can drag the anchor to whichever paragraph (and thus page) you want. There may be better ways to do figures in Word, but unfortunately I don’t know of any. in the references section at the end of this paper d be thnces with plain text (Alt style. However, in order to cross-reference in the references section at the end of this paper d be thnces with plain text (Alt style. However, in order to cross-reference ”
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Figure � SEQ SIGPLAN_Figure \* ARABIC �1�. This figure caption is formatted with the «SIGPLAN Figure caption» paragraph style. The label “� REF _Ref154328964 \h \* MERGEFORMAT ��Figure 1�” has been inserted by selecting Insert > AutoText > SIGPLAN Figure from the menu (which also inserts the period and the obligatory trailing en space). The label can be cross referenced from the main text using Word’s cross referencing facility, i.e. by selecting Insert > Reference > Cross Reference and then SIGPLAN Figure as the category. Cross references usually adopt the style of the source in Word, so you have to reformat it, e.g. by selecting the cross reference and pressing Ctrl + Space, and by adding the \* MERGEFORMAT switch to the corresponding field expression (as in { REF _Ref154328964 \h \* MERGEFORMAT }). You can have the latter done automatically by executing the Finishing Touches macro. Note that the caption was grouped with the figure pane (so Word keeps them together), and the group’s properties were set to make it appear at top left of text area, with distance to text 20 points above/below (Word actually applies this space depending on where the figure is placed). The whole thing is anchored, so it moves from page to page with the paragraph containing the anchor. However, you can drag the anchor to whichever paragraph (and thus page) you want. There may be better ways to do figures in Word, but unfortunately I don’t know them. in the references section at the end of this paper d be thnces with plain text (Alt style. However, in order to cross-reference in the references section at the end of this paper d be thnces with plain text (Alt style. However, in order to cross-reference 

















� If macros are deactivated, you must activate them first, using Word’s Extras > Options > Security > Macro security settings.
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